`
hellobin
  • 浏览: 62690 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 679 - Dropping Balls

    博客分类:
  • UVA
 
阅读更多

 

A number ofKballs are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf nodes of FBT. To determine a ball's moving direction a flag is set up in every non-terminal node with two values, eitherfalseortrue. Initially, all of the flags arefalse. When visiting a non-terminal node if the flag's current value at this node isfalse, then the ball will first switch this flag's value, i.e., from thefalseto thetrue, and then follow the left subtree of this node to keep moving down. Otherwise, it will also switch this flag's value, i.e., from thetrueto thefalse, but will follow the right subtree of this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at 1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered from left to right.

 


For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set to befalse, the first ball being dropped will switch flag's values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being dropped will switch flag's values at node 1, node 3, and node 6, and stop at position 12. Obviously, the third ball being dropped will switch flag's values at node 1, node 2, and node 5 before it stops at position 10.

 

 


Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.

 

 


Now consider a number of test cases where two values will be given for each test. The first value isD, the maximum depth of FBT, and the second one isI, theIthball being dropped. You may assume the value ofIwill not exceed the total number of leaf nodes for the given FBT.

Please write a program to determine the stop positionPfor each test case.

 


For each test cases the range of two parametersDandIis as below:

 

\begin{displaymath}2 \le D \le 20, \mbox{ and } 1 \le I \le 524288.\end{displaymath}

 

 

 

Input

Containsl+2 lines.


Line 1 		 I the number of test cases 
Line 2 		 $D_1 \ I_1$
test case #1, two decimal numbers that are separatedby one blank 
... 		 		 
Line k+1 $D_k \ I_k$
test case #k 
Line l+1 $D_l \ I_l$
test case #l 
Line l+2 -1 		 a constant -1 representing the end of the input file

 

Output

Containsllines.


Line 1 		 the stop position P for the test case #1 
... 		 
Line k the stop position P for the test case #k 
... 		 
Line l the stop position P for the test case #l

 

Sample Input

 

5
4 2
3 4
10 1
2 2
8 128
-1

 

Sample Output

12
7
512
3
255

 

 

本题必需找到数学规律(只模拟最后一个小球),而不能用模拟法,否则超时

 

#define RUN
#ifdef RUN

#include<stdio.h>
int main() {

#ifndef ONLINE_JUDGE
	freopen("679.in", "r", stdin);
	freopen("679.out", "w", stdout); 
#endif

	int cnt;
	int D, I;
  
	scanf("%d", &cnt);

	for(int t=0; t<cnt; t++){
		scanf("%d%d", &D, &I);

		//指向编号为k的小球
		int k = 1;

		//直接模拟最后一个小球的路线
		for(int i = 0; i < D-1; i++)
			//I既代表了第I个小球,又表示了第I次经过编号为k的小球
			//根据经过次数I的奇偶性判断下一个经过小球的编号k'
			//和经过小球k'的次数I'

			// 经过k编号小球奇数次则向左走到编号为2*k的小球
			// 并更新经过2*k小球的次数为(I+1)/2
			if(I%2) { k = k*2; I = (I+1)/2; }
			// 经过k编号小球偶数次则向右走到编号为2*k+1的小球
			// 并更新经过2*k+1小球的次数为I/2
			else { k = k*2+1; I /= 2; }

		printf("%d\n", k);
	}

	return 0;
}

#endif



 

 

 

模拟所有小球,超时

 

//#define RUN
#ifdef RUN

#include<stdio.h>
#include<string.h>
//最大深度
const int MAXD = 20;
//最大节点个数2^MAXD-1
int s[1<<MAXD];
int main() {

#ifndef ONLINE_JUDGE
	freopen("679.in", "r", stdin);
	freopen("679.out", "w", stdout); 
#endif

  int cnt;
  int D, I;
  scanf("%d", &cnt);

  for(int t=0; t<cnt; t++){
	scanf("%d%d", &D, &I);
	// 开关
	memset(s, 0, sizeof(s));
	/*
	for(int j=0; j<5; j++){
		printf("%d", s[j]);
	}
	printf("\n");
	*/
	int k, n = (1<<D)-1;
	for(int i = 0; i < I; i++) {
		k = 1;
		for(;;) {
		//开关转换
		s[k] = !s[k];
		//根据开关状态选择下落方向
		k = s[k] ? k*2 : k*2+1;

		//已经落出界了
		if(k > n) break;
		}
	}
	//出界前的叶子编号
	printf("%d\n", k/2);
  }

  return 0;
}

#endif



 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics