`
hellobin
  • 浏览: 62905 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 514 - Rails

    博客分类:
  • UVA
 
阅读更多

 

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

 


\begin{picture}(6774,3429)(0,-10)\put(1789.500,1357.500){\arc{3645.278}{4.7247}......tFigFont{14}{16.8}{\rmdefault}{\mddefault}{\updefault}Station}}}}}\end{picture}

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has$N \leŸ 1000$coaches numbered in increasing order$1, 2, \dots, N$. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be$a_1. a_2, \dots, a_N$. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

 

Input

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integerNdescribed above. In each of the next lines of the block there is a permutation of$1, 2, \dots, N$The last line of the block contains just 0.

The last block consists of just one line containing 0.

 

Output

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file containsYesif it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it containsNo. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.

 

Sample Input

 

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

 

Sample Output

 

Yes
No

Yes

 

思路:

先用手模拟一遍

如1-2-3-4-5 --> 2-3-1-5-4

要成功实现转换必需:

push(1), push(2), pop(2), push(3), pop(3), pop(1), push(4), push(5), pop(5), pop(4)

具体实现可以用两个指针A和B分别指向(1-2-3-4-5)序列和(2-3-1-5-4)序列,依次移动。

规律就是当A与B指向的元素相等时,立即做push-pop(可省略),把两个指针都向后移一位(表示当前检验元素找到了匹配,进行下一个元素的检验)。

否则就检查栈顶元素是否与B所指向的元素相等,若相等,立刻pop并把B指针向后移一位。

再否则就把A指针指向的元素压入栈内,以待以后可能的匹配。

如果以上情况都不满足,就表示不能实现题目的需求。

 

Solution1:

 

//#define RUN
#ifdef RUN

#include<stdio.h>
const int MAXN = 1000 + 10;
int n, target[MAXN];

int main() {

#ifndef ONLINE_JUDGE
	freopen("514.in", "r", stdin);
	freopen("514.out", "w", stdout); 
#endif

	while(scanf("%d", &n)==1 && n!=0) {
		while(true){
			scanf("%d", &target[1]);
			if(target[1] == 0){
				printf("\n");
				break;
			}
			for(int i = 2; i <= n; i++)
				scanf("%d", &target[i]);

			int stack[MAXN], top = 0;
			int A = 1, B = 1;

			int ok = 1;

			while(B <= n) {
				if(A == target[B]){ A++; B++; }
				else if(top && stack[top] == target[B]){ top--; B++; }
				else if(A <= n) stack[++top] = A++;
				else { ok = 0; break; }
			}

			printf("%s\n", ok ? "Yes" : "No");
		}

	}
	return 0;
}

#endif



Solution2:

 

#define RUN
#ifdef RUN

#include<cstdio>
#include<stack>
using namespace std;
const int MAXN = 1000 + 10;

int n, target[MAXN];

int main() {

#ifndef ONLINE_JUDGE
	freopen("514.in", "r", stdin);
	freopen("514.out", "w", stdout); 
#endif

  while(scanf("%d", &n)==1 && n!=0) {

	while(true){
		scanf("%d", &target[1]);
		if(target[1] == 0){
			printf("\n");
			break;
		}

		for(int i = 2; i <= n; i++)
			scanf("%d", &target[i]);

		stack<int> s;
		int A = 1, B = 1;

		int ok = 1;
		while(B <= n) {
			if(A == target[B]){ A++; B++; }
			else if(!s.empty() && s.top() == target[B]){ s.pop(); B++; }
			else if(A <= n) s.push(A++);
			else { ok = 0; break; }
		}
		printf("%s\n", ok ? "Yes" : "No");
	}
    
  }
  return 0;
}
#endif



 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics