`
hellobin
  • 浏览: 62333 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 694 - The Collatz Sequence

    博客分类:
  • UVA
 
阅读更多

 

An algorithm given by Lothar Collatz produces sequences of integers, and is described as follows:

Step 1:
Choose an arbitrary positive integerAas the first item in the sequence.
Step 2:
IfA= 1 then stop.
Step 3:
IfAis even, then replaceAbyA/ 2 and go to step 2.
Step 4:
IfAis odd, then replaceAby 3 *A+ 1 and go to step 2.

It has been shown that this algorithm will always stop (in step 2) for initial values ofAas large as 109, but some values ofAencountered in the sequence may exceed the size of an integer on many computers. In this problem we want to determine the length of the sequence that includes all values produced until either the algorithm stops (in step 2), or a value larger than some specified limit would be produced (in step 4).

 

Input

The input for this problem consists of multiple test cases. For each case, the input contains a single line with two positive integers, the first giving the initial value ofA(for step 1) and the second givingL, the limiting value for terms in the sequence. Neither of these,AorL, is larger than 2,147,483,647 (the largest value that can be stored in a 32-bit signed integer). The initial value ofAis always less thanL. A line that contains two negative integers follows the last case.

 

Output

For each input case display the case number (sequentially numbered starting with 1), a colon, the initial value forA, the limiting valueL, and the number of terms computed.

 

Sample Input

 

 3 100
 34 100
 75 250
 27 2147483647
 101 304
 101 303
 -1 -1

 

Sample Output

 Case 1: A = 3, limit = 100, number of terms = 8
 Case 2: A = 34, limit = 100, number of terms = 14
 Case 3: A = 75, limit = 250, number of terms = 3
 Case 4: A = 27, limit = 2147483647, number of terms = 112
 Case 5: A = 101, limit = 304, number of terms = 26
 Case 6: A = 101, limit = 303, number of terms = 1

 

 

 

#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 105

long long A, limit;
int cnt;
int casenum = 1;

void play(int casenum){
	cnt = 1;

	long long aA = A;

	while(true){
		if(aA == 1){
			printf("Case %d: A = %lld, limit = %lld, number of terms = %d\n", casenum, A, limit, cnt);
			return;
		}

		if(aA%2 == 0){
			aA = aA/2;
		}
		else{
			aA = 3*aA + 1;
		}

		if(aA > limit){
			printf("Case %d: A = %lld, limit = %lld, number of terms = %d\n", casenum, A, limit, cnt);
			return;
		}

		++cnt;
	}

	
}


int main(){

#ifndef ONLINE_JUDGE
	freopen("694.in", "r", stdin);
	freopen("694.out", "w", stdout); 
#endif


	while(scanf("%lld%lld", &A, &limit)==2 && A!=-1 && limit!=-1){
		play(casenum);
		++casenum;
	}


}


#endif



 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics