`
hellobin
  • 浏览: 62682 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 489 - Hangman Judge

    博客分类:
  • UVA
 
阅读更多

 

In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

     

       ______   
       |  |     
       |  O     
       | /|\    
       |  |     
       | / \    
     __|_       
     |   |______
     |_________|
  4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
  6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

 

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of-1would indicate the end of all games (and input).

 

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

 

You win.
You lose.
You chickened out.

 

Sample Input

 

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

 

Sample Output

 

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.

 

 

 

 

#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 105

int n;
char solution[MAXN];
char guess[MAXN];

int flag[MAXN];

void play(){

	memset(flag, 0, sizeof(flag));
	
	int i, j;
	int wrong = 0;

	for(i=0; i<strlen(guess); i++){

		bool iswrong = true;

		// Check if it is a same character as previous examined one
		char* pch = strchr(guess, guess[i]);
		if(pch!=NULL && pch-guess==i){
			for(j=0; j<strlen(solution); j++){

				if(flag[j]==0 && solution[j]==guess[i]){
					flag[j] = 1;
					iswrong = false;
				}
			}
			if(iswrong){
				wrong++;
			}
			if(wrong >= 7){
				break;
			}
		}
	}

	printf("Round %d\n", n);

	// Examine
	int k = 0;
	for(k=0; k<strlen(solution); k++){
		if(flag[k] == 0){
			if(wrong < 7){
				printf("You chickened out.\n");
				return;
			}
			else{
				printf("You lose.\n");
				return;
			}
		}
	}

	if(k == strlen(solution)){
		printf("You win.\n");
	}

}


int main(){

#ifndef ONLINE_JUDGE
	freopen("489.in", "r", stdin);
	freopen("489.out", "w", stdout); 
#endif

	while(scanf("%d", &n)==1 && (n!=-1)){

		memset(solution, '\0', sizeof(solution));
		memset(guess, '\0', sizeof(guess));
		scanf("%s%s", solution, guess);
		//printf("%s\n", ans);
		//printf("%s\n", guess);

		play();
	}


}


#endif



 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics