`
hellobin
  • 浏览: 62740 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 10361 - Automatic Poetry

    博客分类:
  • UVA
 
阅读更多

 

“Oh God”, Lara Croft exclaims, “it’sone of these dumb riddles again!”

 

In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric caves and medival hallways. Now she is standing in front of some important Germanic looking doorway and has to solve a linguistic riddle to pass. As usual, the riddle is not very intellectually challenging.

 

This time, the riddle involves poems containing a “Schuttelreim”. An example of a Schuttelreim is the following short poem:

 

Ein Kindhaltseinen Schnabel nur,

wennes hangt an der Nabelschnur.

 

/*German contestants please forgive me. I had to modify something as they were not appearing correctly in plain text format*/

 

A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well, even a computer can do that, and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.

Input

The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form

s1<s2>s3<s4>s5

 

wherethe siare possibly empty, strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “...”. Lines willweat most 100 characters long.

Output

For each pair of Schuttelreim lines l1and l2you are to output two lines c1and c2in the following way: c1is the same as l1only that the bracket marks “<” and “>” are removed. Line c2is the same asl2,except that instead of the three dots the string s4s3s2s5should appear.

Sample Input

3

einkind haelt seinen <schn>abel <n>ur

wennes haengt an der ...

weilwir zu spaet zur <>oma <k>amen

verpasstenwir das ...

<d>u <b>ist

...

Sample Output

einkind haelt seinen schnabel nur

wennes haengt an der nabel schnur

weilwir zu spaet zur oma kamen

verpasstenwir das koma amen

dubist

budist

 

 

 

//#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 105
//char l1[MAXN];
//char l2[MAXN];
string l1;
string l2;

void play(){
	bool leftB1 = false;
	bool rightB1 = false;
	bool leftB2 = false;
	bool rightB2 = false;

	string s2, s3, s4, s5;
	s2.clear();
	s3.clear();
	s4.clear();
	s5.clear();

	for(int i=0; i<l1.length(); i++){
		//第一次找到<
		if(!leftB1 && !rightB1 && l1[i]=='<' && !leftB2 && !rightB2){
			leftB1 = true;
			continue;
		}

		//第一次找到>
		if(leftB1 && !rightB1 && l1[i]=='>'  && !leftB2 && !rightB2){
			rightB1 = true;
			continue;
		}

		//找到第一个<>中间的字符
		if(leftB1 && !rightB1  && !leftB2 && !rightB2){
			s2 += l1[i];
			continue;
		}

		//第二次找到<
		if(leftB1 && rightB1 && !leftB2 && !rightB2 && l1[i]=='<'){
			leftB2 = true;
			continue;
		}

		//找到第一个<>到第二个<>之间的字符
		if(leftB1 && rightB1 && !leftB2 && !rightB2){
			s3 += l1[i];
			continue;
		}

		//第二次找到>
		if(leftB1 && rightB1 && leftB2 && !rightB2 && l1[i]=='>'){
			rightB2 = true;
			continue;
		}

		//找到第二个<>中间的字符
		if(leftB1 && rightB1 && leftB2 && !rightB2){
			s4 += l1[i];
			continue;
		}

		//找到第二个<>后面的字符
		if(leftB1 && rightB1 && leftB2 && rightB2){
			s5 += l1[i];
			continue;
		}
	}

	int l1start = l1.find('<');
	string s1 = l1.substr(0, l1start);


	//cout << "s2:" << s2 << endl;
	//cout << "s3:" << s3 << endl;
	//cout << "s4:" << s4 << endl;
	//cout << "s5:" << s5 << endl;
	cout << (s1+s2+s3+s4+s5) << endl;
	string combine = s4+s3+s2+s5;
	int l2start = l2.find("...");
	cout << l2.replace(l2start,3,combine) << endl;
}


int main(){

#ifndef ONLINE_JUDGE
	freopen("10361.in", "r", stdin);
	freopen("10361.out", "w", stdout);
#endif

	int n;
	scanf("%d", &n);
	getchar();
	for(int i=0; i<n; i++){
		l1.clear();
		l2.clear();
		//memset(l1, '\0', sizeof(l1));
		//memset(l2, '\0', sizeof(l2));

		//fgets(l1, MAXN, stdin);
		//fgets(l2, MAXN, stdin);

		getline(cin, l1);
		getline(cin, l2);

		//cout << l1 << endl;
		//cout << l2 << endl;
		play();
	}

}


#endif



分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics