`
hellobin
  • 浏览: 62961 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 10010 - Where's Waldorf?

    博客分类:
  • UVA
 
阅读更多

Given ambyngrid of letters, ($1 \leq m,n \leq 20$), and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

 

 

The input begins with a pair of integers,mfollowed byn,$1 \leqm,n \leq 50$in decimal notation on a single line. The nextmlines containnletters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another integerkappears on a line by itself ($1 \leq k \leq 20$). The nextklines of input contain the list of words to search for, one word per line. These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

 

For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line in the grid where the first letter of the given word can be found (1 represents the topmost line in the grid, andmrepresents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found (1 represents the leftmost column in the grid, andnrepresents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e. the occurence which places the first letter of the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.

Sample Input

1

8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert

Sample Output

2 5
2 3
1 2
7 8
 

 

 

 

 

#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 55

int n;	// Count of test cases
int rows, cols;	// Grid
int m;	// Count of words
char grid[MAXN][MAXN];
char buf[MAXN];
char candicates[8][MAXN];

void printout(){
	for(int i=0; i<rows; i++){
		for(int j=0; j<cols; j++){
			printf("%c", grid[i][j]);
		}
		printf("\n");
	}
}

void strtolower(char* str)
{
	while (*str)
	{
		*str = tolower(*str);
		str++;
	}
}

void getCandicates(int i, int j){
	
	memset(candicates, '\0', sizeof(candicates));
	int buflen = strlen(buf);

	int ii=i, jj=j;

	for(int k=0; k<buflen; k++){
		if(ii>=0 && ii<rows && jj>=0 && jj<cols){
			candicates[0][k] = grid[ii][jj];
		}
		else{
			break;
		}
		// right
		jj++;
	}

	ii=i, jj=j;
	for(int k=0; k<buflen; k++){
		if(ii>=0 && ii<rows && jj>=0 && jj<cols){
			candicates[1][k] = grid[ii][jj];
		}
		else{
			break;
		}
		// left
		jj--;
	}

	ii=i, jj=j;
	for(int k=0; k<buflen; k++){
		if(ii>=0 && ii<rows && jj>=0 && jj<cols){
			candicates[2][k] = grid[ii][jj];
		}
		else{
			break;
		}
		// up
		ii--;
	}

	ii=i, jj=j;
	for(int k=0; k<buflen; k++){
		if(ii>=0 && ii<rows && jj>=0 && jj<cols){
			candicates[3][k] = grid[ii][jj];
		}
		else{
			break;
		}
		// down
		ii++;
	}

	ii=i, jj=j;
	for(int k=0; k<buflen; k++){
		if(ii>=0 && ii<rows && jj>=0 && jj<cols){
			candicates[4][k] = grid[ii][jj];
		}
		else{
			break;
		}
		// up-left
		ii--;
		jj--;
	}

	ii=i, jj=j;
	for(int k=0; k<buflen; k++){
		if(ii>=0 && ii<rows && jj>=0 && jj<cols){
			candicates[5][k] = grid[ii][jj];
		}
		else{
			break;
		}
		// up-right
		ii--;
		jj++;
	}

	ii=i, jj=j;
	for(int k=0; k<buflen; k++){
		if(ii>=0 && ii<rows && jj>=0 && jj<cols){
			candicates[6][k] = grid[ii][jj];
		}
		else{
			break;
		}
		// down-left
		ii++;
		jj--;
	}

	ii=i, jj=j;
	for(int k=0; k<buflen; k++){
		if(ii>=0 && ii<rows && jj>=0 && jj<cols){
			candicates[7][k] = grid[ii][jj];
		}
		else{
			break;
		}
		// down-right
		ii++;
		jj++;
	}
}


bool check(){
	
	for(int i=0; i<8; i++){
		if(strlen(buf) != strlen(candicates[i])){
			continue;
		}

		if(strncmp(buf, candicates[i], strlen(buf)) == 0){
			return true;
		}
	}

	return false;
}


void play(){
	//printf("%s\n", buf);
	for(int i=0; i<rows; i++){
		for(int j=0; j<cols; j++){
			getCandicates(i, j);
			if(check()){
				printf("%d %d\n", i+1, j+1);
				return;
			}
		}
	}
	//getCandicates(1, 0);
	//for(int i=0; i<8; i++){
	//	printf("%s\n", candicates[i]);
	//}
}


int main(){

#ifndef ONLINE_JUDGE
	freopen("10010.in", "r", stdin);
	freopen("10010.out", "w", stdout);
#endif
	
	scanf("%d", &n);
	char c;

	memset(grid, '\0', sizeof(grid));
	bool blank = false;

	for(int i=0; i<n; i++){

		if(blank){
			printf("\n");
		}

		scanf("%d%d", &rows, &cols);
		getchar();
		for(int j=0; j<rows; j++){
			for(int k=0; k<cols; k++){
				scanf("%c", &c);
				if(c>='A' && c<='Z'){
					c = c - 'A' + 'a';
				}
				grid[j][k] = c;
			}
			getchar();
		}

		//printout();

		scanf("%d", &m);
		for(int j=0; j<m; j++){
			memset(buf, '\0', sizeof(buf));
			scanf("%s", buf);
			strtolower(buf);
			play();
			//break;
		}

		blank = true;
	}


}


#endif



总结一个能把c string转大小写的方法

 

void strtolower(char* str)
{
	while (*str)
	{
		*str = tolower(*str);
		str++;
	}
}



分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics